Communauté d'entraide Molotov

Question en attente de réponse

Ubuntu 16.04 même utilisateur en ssh FUSE error en console totu fonctionne ? Ordinateur (Windows, Mac, Linux)

Bonjour,

Desktop Ubuntu 16.04 (up to date)
Fuse installé
utilisateur X (je cherche à lancer molotov.AppImage depuis une console)
... test de base : login de X sur la console
... AppImage se lance et tout fonctionne
... login de X en SSH depuis un site distant (même utilisateur)
... Erreur au lancement de l'AppImage
Cannot mount AppImage, please check your FUSE setup.
You might still be able to extract the contents of this AppImage
if you run it with the --appimage-extract option.
See https://github.com/AppImage/AppImageKit/wiki/FUSE
for more information
??? l'utilisateur étant le même ??? je ne comprends pas le pourquoi
SI en SSH j'extrait l'image (bsdtar) et l’exécute .AppRun (je dois positionner BIN=Molotov pour ne pas avoir une erreur exec (sans chemin)) ... là Molotov se lance normalement ???

Avez-vous une idée ou une piste ?

Merci.
Fred.

fred.lacrima
fred.lacrima

fred.lacrima

Niveau
0
27 / 100
points

Réponses

fred.lacrima
fred.lacrima

fred.lacrima

Niveau
0
27 / 100
points

Bonsoir,

Pour compléter les trace du lancement sous le même utilisateur l'un depuis une console (ok) l'autre depuis une session ssh (bad)
tronqués (pour le OK) juste après l'erreur sur la session SSH sur le BAD

Fred.

fred.lacrima
fred.lacrima

fred.lacrima

Niveau
0
27 / 100
points

Bonjour,

Je reviens vers vous ... car mon problème reste entier (Merci à Fodil ... mais je n'ai pas de problème de lancement en mode "console")

A priori le problème vient quand je lance molotov depuis une session SSH ... donc dans un mode "non interactif" alors que en mode console cela fonctionne.

Comme je veux piloter à distance un serveur multimédia avec sortie HDMI mais sans clavier / souris (hors debug) ... je voulais utiliser une connexion SSH pour lancer mes applications, cela fonction sans soucis avec Kodi ou PlexMediaPlayer ... mais PAS avec les AppImage (depuis j'ai vérifié avec d'autres (Calibre par ex.))

Donc le problème est peut-être (certainement) lié au format AppImage et à son mode de fonctionnement ... plus qu'à Molotov lui-même ...

Je contourne le problème en lançant dans un shell interactif sur la console ... depuis ma session SSH ... mais c'est bancal ...

J'utilise pas mal Ubuntu et la virtualisation ... mais suis débutant avec Appimage ... donc peut-être une mauvaise manipulation ???

Merci de votre aide ... et si vous avez une autre idée ...

Fred.

Bonjour Fred,

Au temps pour moi, j'avais mal compris...

Je pense toutefois qu'il est préférable de demander de l'aide plutôt sur des forums spécialisés Linux pour une demande si poussée.

A bientôt !

©Molotov 2019