Communauté d'entraide Molotov

Question en attente de réponse

Client Linux 4.2.2 - The SUID sandbox helper binary was found, but is not configured correctly. Ordinateur (Windows, Mac, Linux)

Pas de problème en 4.2.0.
Depuis la mise à jour en 4.2.2 ça ne fonctionne plus avec le message suivant :
$ ./molotov.AppImage
[4502:0108/133807.308135:FATAL:setuid_sandbox_host.cc(157)] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I'm aborting now. You need to make sure that /tmp/user/1000/.mount_molotoN98gv9/chrome-sandbox is owned by root and has mode 4755.
Trace/breakpoint trap

Cela fonctionne avec --no-sandbox, mais :

  • je ne récupère pas ma configuration,
  • en mode PIP (réduit) la fenêtre s'affiche à moitié à l’extérieur de l'écran, en haut à gauche. Du coup il n'est pas possible de le déplacer.

mltv
mltv

mltv

Niveau
0
24 / 100
points

Réponses

zozo.hack
zozo.hack

zozo.hack

Niveau
0
11 / 100
points

Je suis sous debian 10 et j'ai eu le même message d'erreur.
J'ai pu lancer l'appli avec le --no-sandbox. Merci

pberghe
pberghe

pberghe

Niveau
0
12 / 100
points

Bonjour,

Même souci rencontré (Debian Buster) au moment où je découvre l'appli et souhaite l'installer. le souci semble lié à la politique de sécurité Debian concernant le sandboxing. Un peu de recherche sur le message d'erreur m'a conduit sur cette page: https://github.com/tutao/tutanota/issues/1565 qui traite précisément de ce problème (même s'il s'agit d'une autre appli). On y trouve un "workaround" qui a parfaitement fonctionné chez moi, qui consiste à ajouter au fichier /etc/sysctl.conf la commande suivante:
kernel.unprivileged_userns_clone=1.
Redémarrage nécessaire.

Espérant que ça puisse aider.

<p/>
02-05-20 Le bouton "répondre à cette question" me renvoie sur une erreur 404, du coup j'édite mon précédent post pour répondre!...
@mltv:
Ta solution est évidemment moins "brutale" que la mienne. J'ai du coup adapté en suivant ton conseil: un petit script .sh appelé par la commande de lancement de molotov, et hop! Tout roule à la perfection, la sécurité en plus. Merci pour le partage.

Niffo
Niffo

Niffo

Niveau
0
11 / 100
points

+1 Même problème sous Debian 10

Sad S.
Sad S.

Sad S.

Niveau
0
11 / 100
points

Même problème avec devuan

mltv
mltv

mltv

Niveau
0
24 / 100
points

J'ai résolu mon problème en m'inspirant de la solution trouvée par pberghe.
Il n'est pas nécessaire de redémarrer ni de réduire de façon permanente la sécurité.
Voici mon script pour lancer Molotov :

-- 8< --
sudo /usr/sbin/sysctl kernel.unprivileged_userns_clone=1
molotov.AppImage &
sleep 5
sudo /usr/sbin/sysctl kernel.unprivileged_userns_clone=0
-- >8 --

Jérôme D.
Jérôme D.

Jérôme D.

Niveau
0
11 / 100
points

sous DEBIAN 5 GNU/Linux je souhaite remercié grandement - mltv - qui m'a totalement déverrouillé du même problème SUID sandox. Cela ne marchait pas avec : --no-sandbox , plantage+reboot. Grâce au script de -mltv- plus aucun soucis tout fonctionne encore merci à toi !! ^^

©Molotov 2019